The Tutorial Pulse Lab and LabScribe Software
Overview

Figure T-T-S1: The front and rear panels of the TA-ROAM.
The data acquisition unit used in the iWorx teaching kits is the TA-ROAM. The inputs of channels A1
and A2 of this unit have built-in pressure sensors. Channels A3 and A4 are configured as BNC inputs.
Almost any peripheral device with a single-ended output less than + 5 Volts, like a pH meter or a
spectrophotometer, can be safely connected to the BNC input. Instruments that require an external
power source, like many transducers, can be connected directly to Channels A5 and A6 of the TA,
without the need for a conditioning amplifier. The DIN8 inputs of these two channels can provide +/- 5
Volts (DC) for the excitation of transducers, as well as inputs for recording the output signals from the
transducers or probes connected to these channels. The other channels are used for specific transducers
as shown in the labs. The iWire ports are for the iWire biopotential recording devices. The mode
controls for these channels invoke the appropriate filter settings for recording electrocardiograms
(ECG), electroencephalograms (EEG), electromyograms (EMG), electroculograms (EOG), and other
signals like nerve action potentials. The iWire cable also allows for direct recording of galvanic skin
response (GSR). The unit includes the ROAM wireless ECG, EMG, and other biopotential recorder. It
sits in the docking port on the top of the TA. The ROAM has a battery life of approximately 8 hours
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and needs to be recharged prior to use. As long as the ROAM is in the dock and the TA is plugged in,
the ROAM will charge. It takes about an hour for a full charge.
The rear panel allows for the connection of the EM-220 event marker. In addition to its function as a
recording unit, the TA has a stimulator. The output can be used to evoke nerve and muscle activity.
The LabScribe software and labs can easily be installed from our website. LabScribe is usually found
in the iWorx folder located in the Program Files folder on the computer’s hard drive. The software
permits electrical signals to be displayed on the computer screen in a format that resembles a laboratory
strip chart recorder. The signals being recorded by the TA can be different sizes and durations. The user
can easily adjust the software so that the signals are sized and displayed properly. This tutorial
describes how to make these adjustments and how to make simple measurements from recordings.
To assist users in recording data quickly and efficiently during the experiments included in the iWorx
Physiology Lab Manual, the LabScribe recording software and the TA data recording unit can be
configured for a particular experiment through a standard settings file within the software. At most,
only minor adjustments are needed to display data in the best format.
Use the following tutorial to acquaint yourself with the most commonly used features of LabScribe.
Additional information about the software is available from the Help menu on the LabScribe Main
window.

Equipment Required
PC or Mac Computer
TA data acquisition unit, USB cable, TA power supply
PPG-320 pulse plethysmograph

IXTA Setup
1. Place the TA on the bench, close to the computer. Use the USB cable to connect the computer to
the USB port on the rear panel of the TA.
2. Plug the power supply for the TA into the electrical outlet. Insert the plug on the end of the
power supply cable into the labeled socket on the rear of the TA. Use the power switch to turn
on the unit. Confirm that the power light is on.

Start the Software
1. Click on the LabScribe shortcut on the computer’s desktop to open the program.
2. On the Main window, pull down the Settings menu and select Load Group.
3. Locate the folder that contains the settings group, IPLMv7Complete.iwxgrp. Select this group
and click Open.
4. Pull down the Settings menu, again. Select the Tutorial-Pulse settings file from the Tutorial list.
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5. After a short time, LabScribe will appear on the computer screen as configured by the TutorialPulse settings file.
6. Once the settings file has been loaded, click the Experiment button on the toolbar to open any
of the following documents:
•
•
•
•

Appendix
Background
Labs
Setup (opens automatically)

Pulse Sensor Setup
1. Locate the PPG-320 pulse sensor and plug it into the PT port on the front of the TA.

Figure T-T-S2: The PPG-320 pulse plethysmograph plugged into the PT port.
2. Place the plethysmograph on the volar surface (where the fingerprints are located) of the distal
segment of the subject’s middle finger or thumb, and wrap the Velcro strap around the end of
the finger to attach the unit firmly in place.
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The Tutorial Pulse Lab and LabScribe Software
Exercise 1: Recording Pulses
1. Click on the Record button, located on the upper right side of the LabScribe Main window. The
signal should begin scrolling across the screen.
2. Click on the AutoScale All button on the toolbar. The pulse signals and heart rate histogram
should expand to fill the channel windows.
3. Click Stop to halt recording; your record should look like the figure below. If the signal on the
Pulse channel is upside down when compared to trace in figure, click on the downward arrow to
the left of the channel title and select the Invert function. The trace should now look similar to
the one in the figure.

Figure T-T-L1: Pulse and heart rate recordings in the LabScribe Main window.
4. Select Save As in the File menu, type a name for the file. Click on the Save button to save the
data file.
Exercise 2: Explore the LabScribe Main Window
Once you have recorded data, explore some of the functions of the LabScribe software that are
available on the Main window by clicking on buttons, or pulling down menus and selecting functions.
See what happens to the images on the recording channels as you change the Display Time, Zoom In or
Out, or Invert the signal.
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The configuration of the Main window used for this experiment was designed by manipulating some of
the controls on the Main window and some of the controls on other windows, like the Preferences
dialogue window available from the Edit menu. The configuration used for this experiment was saved
as the settings file, Tutorial-Pulse-LS2, that you selected from the Settings menu and are using for this
experiment.
Additional tools in the LabScribe software are covered in Exercises 3 through 6.
Channel Recording Area
Each channel has its own recording area and its own controls and indicators:
•

Channel Menu has controls for inverting and copying the graph, hiding and minimizing the
channel, changing the title of the channel, converting units, and setting the scale of the Y-axis.

•

Channel Title, which can be changed through the Channels Menu or the Preferences dialogue
window.

•

Channel Mode and Function identifies the input used and any computed function being
performed on the input signal. A pull-down setup menu opens when this area is clicked.

•

Zoom In button doubles the height of the signal displayed without altering the real amplitude of
the signal. Zoom Out button halves the height of the signal displayed without altering the real
amplitude of the signal.

•

AutoScale button increases the height of the signal displayed to within 5% of the upper and the
lower limits of the Y-axis.

•

Add Function button opens a pull-down menu used to select a computed function to be
performed on the channel. When the function is selected, the additional channel and any
controls for programming the function open automatically.

•

Values display lists the Y-value of a data point at the position of a single cursor, or the
difference between the Y-values of the points identified by two cursors.

•

Position the trace on a channel by placing the cursor on the recording area, holding down the
mouse button, and sliding the trace up or down.

•

Adjust the height of an individual channel by placing the cursor on the margin between that
channel and the channel above or below it. The cursor turns into a double-headed arrow when it
is proper location for adjusting the height of the channel. Hold down the mouse button and slide
the margin up or down to change the height of the channel display.
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Figure T-T-L2: Control buttons and values for a typical LabScribe recording channel.

Time Displays and Mark Controls
Just above the uppermost channel in the LabScribe Main window are the displays for the time
parameters of the recording and controls for marking of the recording:
•

Speed is the number of samples taken each second of the recording. Sampling rate is controlled
from the Preferences dialogue window on the Edit menu.

•

Display Time is the length of time of recorded data that is seen on the Main window. Display
time is controlled from the Preferences dialogue window on the Edit menu or by the Display
Time icons on the LabScribe toolbar.

•

Mark button is clicked to place a mark at a point of interest on a live recording. Clicking the
Enter key on the keyboard will also add marks to a live recording.

•

Mark Menu is opened by clicking on the arrow to the right of the Mark button. This menu has
controls for adding and deleting preset marks, and resetting the positions of marks. Mark Box is
an area where comments associated with preset marks are composed. Preset marks can be added
to a list by using the Add function in the Marks menu. To activate a preset mark for use, click
on the arrow at the right side of the Mark Box and select the preset mark to be used.

•

Time or T2-T1 displays the time of the recording at the position of a single cursor, or the
difference in time between the positions of two cursors placed on the recording.
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Figure T-T-L3: The menus, toolbars, displays and controls of the LabScribe Main window.

Toolbars
Just above the Time Displays and Mark Controls are the toolbars for manipulating data files, LabScribe
windows, time displays, cursors, screen views, and output sequences.
File Toolbar
•

New File: Click on this icon to open a new data file using the current settings for the program.

•

Open File: Click on this icon to open data files that were previously recorded and saved.

•

Save File: Click on this icon to save the current data in a file.

LabScribe Toolbar
•

Main Window: Click on this icon to return to the window where recorded data is first displayed
and on-line computed functions can be performed.

•

Analysis Window: Click on this icon to send the data between the left and right margins of the
Main window to the Analysis window for additional measurements.

•

XY Plot: Click on this icon to plot the amplitudes of two channels, like pressure and volume,
against each other. This plots one channel to another, not one channel to time.

•

FFT: Click on this icon to perform a Fast Fourier Transform on data for determining the power
spectrum of the waveform.

•

Journal: Click on this icon to open a notepad for recording critical data points, data windows,
comments, and responses to questions for their eventual transfer to word processing, graphing,
and other programs used for expressing experimental results.

•

Marks Window: Click on this icon to open the list of marks created during the data recording.
The comments associated with the marks can be edited.
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•

Stimulator: Click on this icon to open the Stimulator Control Panel under the toolbar. The type
of stimulus and its parameters are selected from the control panel. The stimulator is only needed
in experiments that require the generation of action potentials or muscle twitches.

Display Time Controls
•

Half Display Time: Click on this icon the halve the length of the recording displayed on the
screen. For example, if ten seconds of data is displayed on the screen, clicking this icon will
display only five seconds.

•

Double Display Time: Click on this icon the double the length of the recording displayed on the
screen. For example, if ten seconds of data is displayed on the screen, clicking this icon will
display twenty seconds.

Cursors
•

Two Cursors: Click on this icon to place two cursors on the window. These cursors can be used
for measuring the differences in time or amplitude for the positions of the two cursors.

•

One Cursor: Click on this icon to place a cursor on the window. This cursor can be used for
measuring the time and amplitude at the position of the cursor.

View Controls
•

Current View: This box displays the name of the current combination of channels, or view,
displayed on the window.

•

View Menu: Displays the controls for creating, copying, naming, and editing views.

Sequence Controls
•

Current Sequence: This box displays the name of the sequence of commands used to automate
sampling and stimulation.

•

Sequence Menu: Displays the controls for starting, stopping, editing, opening, and saving
sequences of commands.

Exercise 3: Making Marks on a Recording
Large amounts of data can be recorded with LabScribe software. However, to be useful, the data that is
interesting needs to be located and retrieved easily. Specific sections of data can be located or
distinguished from other sections by placing marks and comments at those locations in the data file.
Marks, with or without text comments attached, can be placed on the data during or after the recording.
The text comments associated with marks can also be composed and saved, before the recording
begins, in the Preset Mark List.
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Entering Marks While Recording
Practice adding marks with comments during a recording.
1. Make sure the pulse transducer is attached to the middle finger of the subject and connected to
the recording unit in the correct manner. Also, make sure the LabScribe software is configured
to record data.
2. Click Record. Adjust the height of the traces on the Pulse and Heart Rate channels by using the
AutoScale All button.
3. During data recording, an active text cursor appears in the Mark Box. Type the subject’s name
in the Mark Box using the keyboard
4. Click on the Mark button or press the Enter key on the keyboard to place the mark on the
recording.
5. Use the same procedure to place additional marks and comments while continuing to record
data.
6. Click on the Stop button to end the recording. Open the File menu and select Save.

Making and Entering Preset Marks
Marks can be composed and added to a list before data recording begins.
1. Before recording another block of data, move the screen cursor to the Mark Box and click the
mouse button to make a text cursor appear in this box.
2. Write a comment in the Mark Box. Pull down the Mark menu and select Add to Mark Presets.
3. Pull down the Preset Mark List, that is to the right of the Mark Box, and confirm the presence
of the preset mark you just created.
4. Click Record. Adjust the height of the traces on the Pulse and Heart Rate channels by using the
AutoScale buttons.
5. Pull down the Preset Mark List and select the preset mark you composed. The preset mark
should appear in the Mark Box.
6. Click on the Mark button on the Main window or press the Enter key on the keyboard to place
the preset mark on the recording.
7. Click on the Stop button to end the recording. Open the File menu and select Save.

Entering Marks on Recorded Data
Additional marks and comments can be added to a data file after the recording is completed.
1. Find a region of interesting data in your current data file.
2. Click on the One Cursor icon on the Main window toolbar.
3. Use the mouse to position the cursor on the data of interest.
4. Put a text cursor in the Mark Box and compose a comment.
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5. Click on the Mark button on the Main window, or on the Enter key on the keyboard, to place
the added mark on the recorded data.
6. Open the File menu and select Save.

Exercise 4: Analyzing Your Data in the Main Window
Time and amplitude measurements can easily be performed on the Main window using cursors. The
values obtained can be saved in the Journal along with other notes pertinent to the experiment.
Navigating the Main Window
There are two ways to navigate through a data file in the Main window to reach regions of interest:
scrolling or using marks.
Scrolling
1. Locate the scroll bar below the time marks on the lower margin of the Main window.
2. To move the recording to the left or the right in small increments, click on the arrows at the
ends of the scroll bar.
3. To scroll slowly through the recording, click on and hold on the arrows at either end of the
scroll bar.
4. To scroll quickly through the recording, click on and hold on the slider as you move it to the left
or the right.
5. If you click on the Half or Double Display Time icons on the toolbar, the width of the slider will
change in proportion to the display time of the data file. When the display time on the screen is
longer, the slider is longer.

Using Marks
1. Open the Marks window to see a list of the marks. The Marks window can be opened by
clicking the Marks icon on the toolbar. The Marks window can also be opened by pulling down
the View menu and selecting Marks from the list.
2. Click on the Number of the mark to select a mark, click on the GoTo Mark button. The Mark
window will disappear and the region of the data file around the selected mark will be displayed
on the Main window.

Figure T-T-L4: The Marks Window.
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Figure T-T-L5: The View menu.

Making Measurements on the Main Window
Amplitudes, differences in amplitudes, times, and differences in times of waves displayed on the Main
window can be taken using the cursors. The cursors are vertical blue lines that appear on each channel
displayed in the Main window when either of the two Cursor icons in the toolbar are clicked.
Using two cursors:
1. Click on the Two Cursors icon in the toolbar to place two vertical blue bars on the Main
window.
2. Click on and drag the cursors, to the left or to the right, to place them of the peaks of two
adjacent pulses on the Pulse channel. The difference in time between the peaks is the value
labeled T2-T1, which is displayed next to the Record button.

Figure T-T-L6: Two cursors used to measure the period (T2-T1) of a pulse wave.
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3. Click on and drag one of the cursors to the baseline of the pulse recording to the left of a pulse
peak. Place the other cursor on the peak of the pulse wave to the right of the first cursor.This
difference in the amplitude is the value labeled as V2-V1, which is displayed below the Record
button.

Figure T-T-L7: Two cursors used to measure the amplitude (V2-V1) of a pulse wave.

Using a single cursor:
1. Click on the One Cursor icon in the toolbar to place a vertical blue line on the Main window.

Figure T-T-L8: One cursor used to measure the heart rate of the subject from the data on the Heart
Rate channel.
2. Click on and drag the cursor to a plateau on the Heart Rate channel. The time of the recording at
this position is the value labeled Time, which is displayed next to the Record button. The Value
for the amplitude at this position is the heart rate of the subject at that moment in time, which is
displayed below the Record button.
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The Journal
The Journal is a window that can be used as a notebook. Notes about the experiment and values from
measurements on the Main window can be typed directly into the Journal. Also, recordings on the
screen and data in tables can be copied and pasted into the Journal. From the Journal, the items present
can be pasted into other programs, or printed directly.
1. Open the Journal by either clicking on the Journal icon on the toolbar or pulling down the View
menu and selecting Journal.
2. Use the keyboard to type a note regarding this experiment or the values of the measurements
taken with the cursors in the Journal.
3. Display ten seconds of pulse data on the Main window. Use the Display Time icons or the
Display Time box on the Preferences dialogue window to set the Display Time.
4. Copy the data on the Main window to the clipboard file by selecting the Copy command in Edit
menu.
5. Place a text cursor on the Journal window by clicking on the open area of the window. Use the
Paste icon on the Journal toolbar, which is on the top margin of the Journal window, to paste a
copy of the data from the Main window into the Journal.
6. Open the File menu and select Save.
7. Click on the Journal icon on the toolbar or pull down the View menu and select Journal to close
the Journal.

Exercise 5: Analyzing Your Data in the Analysis Window
Additional analyses can be performed on data displayed in the Analysis window through a number of
functions that include derivatives, integrals, and general parameters.

Selecting Data for the Analysis Window
The segment of the recording that is displayed on the Main window is the data that can be transferred
easily to the Analysis window.
1. Locate a five-second section of the pulse recording with representative pulse waves. Use the
Display Time icons or the Display Time box on the Preference window to adjust the Display
Time of the Main window to 5 seconds.
2. Click on the Analysis window icon in the toolbar or select Analysis from the View menu to
transfer the data displayed in the Main window to the Analysis window.
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Figure T-T-L9: Pulse and heart rate data in the Analysis window.

Navigating in the Analysis Window
Channels and data are displayed on the Analysis window as they are on the Main window. However,
you will find that some displays, like Value or Time, will appear in tables above each channel. Also,
some controls, like AutoScale, appear under functions on the Channel menu or in shortcuts like the
menu that appears when the Y-axis is clicked.
•

Scrolling
•

•

Marks
•

•

Click on the Display Time icons to change the length of the recording shown in the
window.

Channel Margins
•

•

Use the Go To button on the Marks window to position the data around the selected
mark in the center of the window.

Display Time
•

•

Use the slider and arrows on the scroll bar to move the recording to the left or the right.

Click on and drag the margins between channels to increase or decrease the heights of
channels.

Trace Position
•

Click on and drag the trace to adjust its vertical position on a channel.
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•

Channel Stacking
•

Click on the Stack/Superimpose button in the lower left corner on the Analysis window
to superimpose the channels upon each other. Click on the Stack button, a second time,
to stack the channels above and below each other.

Figure T-T-L10: The Stack/Superimpose button toggles between two modes: stack seen on the left and
superimpose seen on the right.
•

Channel Menu
•

Pull down the Channel menu to copy, hide, delete the selected channel, and more. Other
functions allow data to be copied from the Analysis window to the Journal in tabular
format

Making Measurements on the Analysis Window
Measurements on data displayed in the Analysis window are performed using cursors and functions
selected in the following manner:
1. Click on the add function button to open a menu of mathematical functions that can be
performed on the data displayed in the Analysis window.
2. Open the submenus to familiarize yourself with the parameters available in each category:
•

General: provides amplitudes and times of the data at the positions of the cursors,
differences in amplitudes and times between the data, the maximum and minimum
values of the data between the cursors, and more.

•

Derivative: provides the slope of the data at the positions of the cursors, and the
maximum, minimum, and mean slope of the data between the cursors.

•

Integral: provides the area or absolute area under the recording, or the integral or the
absolute integral of the recording, between the cursors.
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Figure T-T-L11: The Add Function menu in the Analysis window.
3. Open the General category and select Value1. Open the General category, three additional
times, to select Value 2, V2-V1, and T2-T1. After each function is selected, the name of its
parameter appears on the Function Table. The values of the each parameter on each channel
appear on a table across the top of each channel.
4. Click on the Two Cursor icon on the toolbar. Place one cursor at the beginning of a pulse wave
displayed on the Pulse channel. Place the second cursor at the beginning of an adjacent pulse
wave.
5. The values, in the table above the recording area of the Pulse channel, are the amplitudes at the
cursors (Values 1 and 2), the difference in the amplitudes at those cursors (V2-V1), and the time
between the cursors (T2-T1).
6. The values, in the table above the recording area of the Heart Rate channel, are the heart rates at
the cursors (Values 1 and 2), the difference in the heart rates at those cursors (V2-V1), and the
time between the cursors (T2-T1).
7. Create a table of these parameters and their values in the Journal by transferring the titles and
the values of the parameters with the following steps:
•

Go to the Channel menu of any channel and select Add Title to Journal to create a
labeled header for the table;

•

Go to the Channel menu of any channel and select Add All Data to Journal to add data
from all channels to the table, or;

•

Go to the Channel menu of a specific channel and select Add Ch. Data to Journal to add
data from the selected channel to the table.
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Exercise 6: Applying a Computed Function to Your Data
The data files generated or used in the previous exercises all displayed two channels of data, Pulse and
Heart Rate. The data recorded on the Pulse channel is a recording of the response of the pulse
transducer to the rate of change in the pulse pressure in the finger of the subject. The trace displayed on
the Heart Rate channel is derived from the data on the Pulse channel. On the Heart Rate channel, a
mathematical function is programmed to measure and convert the time between the peaks of the pulse
waves into the subject’s pulse rate (which is equal to the subject’s heart rate) and display the rate on the
Main window as a histogram.
In this exercise, you will learn how to apply another computed function, the Standard Integral, to your
pulse recording.
1. Display the pulse data recorded from your subject on the Main window.
2. Adjust the Display Time of the Main window to ten seconds by either using the Half or Double
Display Time icons on the toolbar or entering the Display Time in the appropriate box on the
Preferences dialogue window, which is available from the Edit menu.
3. To select the new computed function to be performed on the pulse data, click on the add
function button on the Pulse channel. The Computed Function menu will appear.
4. Use the screen cursor to highlight Integral. Select Standard from the list of available integral
functions. When the selection is made, an additional channel appears on the Main window
behind the Integral Setup window.

Figure T-T-L12: The Computed Function Menu.

Figure T-T-L13: The Integral Setup window.
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5. On the Integral Setup window, program the parameters for the integral function that will be
performed on the pulse data. Pull down the Reset menu and select Reset After. In the box that
appears to the right of the Reset menu, enter 30 seconds. In the box below the reset time, set the
first 5 seconds of the recording as zero. Click OK.
6. Click on the AutoScale button on the new computed channel to magnify the trace on that
channel.
7. Pull down the Channels menu on the new computed function channel and select Title. Change
the name of channel to Pulse Integral. Click OK.
8. Measure the amplitudes and periods of a couple of the waves on Pulse Integral channel using
the techniques learned in either Exercise 3 on the Main window or Exercise 4 on the Analysis
window.

Figure T-T-L14: Pulse (top), heart rate (middle), and pulse integral (bottom) displayed on the Main
window.
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