
The Tutorial ECG Lab and LabScribe Software

Overview

Figure T-T-S1: The front and rear panels of the IXTA.

The data acquisition unit used in the iWorx teaching kits is the TA-ROAM. The inputs of channels A1 

and A2 of this unit have built-in pressure sensors. Channels A3 and A4 are configured as BNC inputs. 

Almost any peripheral device with a single-ended output less than + 5 Volts, like a pH meter or a 

spectrophotometer, can be safely connected to the BNC input. Instruments that require an external 

power source, like many transducers, can be connected directly to Channels A5 and A6 of the TA, 

without the need for a conditioning amplifier. The DIN8 inputs of these two channels can provide +/- 5 

Volts (DC) for the excitation of transducers, as well as inputs for recording the output signals from the 

transducers or probes connected to these channels.  The other channels are used for specific transducers

as shown in the labs.  The iWire ports are for the iWire biopotential recording devices.  The mode 

controls for these channels invoke the appropriate filter settings for recording electrocardiograms 

(ECG), electroencephalograms (EEG), electromyograms (EMG), electroculograms (EOG), and other 
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signals like nerve action potentials. The iWire cable also allows for direct recording of galvanic skin 

response (GSR).  The unit may include the ROAM wireless ECG, EMG, and other biopotential 

recorder. It sits in the docking port on the top of the TA.  

The optional ROAM wireless ECG/EMG recorder has a battery life of approximately 8 hours and 

needs to be recharged prior to use.  As long as the ROAM is in the dock and the TA is plugged in, the 

ROAM will charge.  It takes about an hour for a full charge.

The rear panel allows for the connection of the EM-220 event marker. In addition to its function as a 

recording unit, the TA has a stimulator. The output can be used to evoke nerve and muscle activity.

The LabScribe software and courseware can easily be installed from our website. LabScribe is usually 

found in the iWorx folder located in the Program Files folder on the computer’s hard drive. The 

software permits electrical signals to be displayed on the computer screen in a format that resembles a 

laboratory strip chart recorder. The signals being recorded by the IXTA can be different sizes and 

durations. The user can easily adjust the software so that the signals are sized and displayed properly. 

This tutorial describes how to make these adjustments and how to make simple measurements from 

recordings. 

To assist users in recording data quickly and efficiently during the experiments included in the iWorx 

Physiology Lab Manual, the LabScribe recording software and the IXTA data recording unit can be 

configured for a particular experiment through a standard settings file within the software. At most, 

only minor adjustments are needed to display data in the best format.

Use the following tutorial to acquaint yourself with the most commonly used features of LabScribe. 

Additional information about the software is available from the Help menu on the LabScribe Main 

window.

Equipment Required

PC or Mac Computer

IXTA data acquisition unit and power supply

USB cable

iWire-B3G biopotential cable and electrode lead wires

Disposable ECG electrodes

IXTA Setup

1. Place the TA on the bench, close to the computer. Use the USB cable to connect the computer to

the USB port on the rear panel of the TA.

2. Locate the iWire-B3G ECG cable and electrode lead wires in the iWorx kit.

3. Insert the connector on the end of the iWire-B3G cable into the isolated inputs of the iWire 1 

channel of the IXTA.  Refer to Figure T-T-S2: The iWire-B3G with three lead wires attached 

connected to the IX-TA.
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4. Plug the power supply for the TA into the electrical outlet. Insert the plug on the end of the 

power supply cable into the rear of the TA. Use the power switch to turn on the unit. 

Start the Software

1. Click on the LabScribe shortcut on the computer’s desktop to open the program.

2. On the Main window, pull down the Settings menu and select Load Group.

3. Locate the Complete Settings folder that contains the settings group, IPLMv7Complete.iwxgrp. 

Select this group and click Open.

4. Pull down the Settings menu, again. Select the Tutorial-ECG-iWireB3G settings file from the 

Tutorial list.

5. Once the settings file has been loaded, click the Experiment button on the toolbar to open any 

of the following documents:

• Appendix

• Background

• Labs

• Setup (opens automatically)

Figure T-T-S2: The iWire-B3G with three lead wires attached connected to the IX-TA.
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ECG Cable Setup

1. Insert the connectors on the red, black, and green electrode lead wires into the matching sockets

on the iWire-B3G.

2. Instruct the subject to remove all jewelry from their wrist and ankles.

3. If the subject has used lotion, use an alcohol swab to clean and scrub a region with little or no 

hair, on the inside of the subject’s right wrist or under the clavicle. Let the area dry.

4. Snap the 3 leads (red, black and green) onto the electrodes. Remove the disposable ECG 

electrodes from the plastic shield.

5. Place the electrodes on the subject:

• the red (+1) lead is attached to either the left ankle, left wrist or under the left clavicle. 

Using the left ankle will give the most accurate ECG waves,

• the black (-1) lead is connected to the right wrist or under the right clavicle,

• the green (ground) lead is connected to the right ankle or the lower right abdomen.

6. Instruct the subject to sit quietly with their hands in their lap. If the subject moves, the ECG 

trace will move off the top or bottom of the screen. If the subject moves any muscles in the 

arms or upper body, electromyograms (EMGs) from the muscles will appear on the ECG 

recording as noise.

7. Open the lab by clicking the Experiment tab and Labs.
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The Tutorial ECG Lab and LabScribe Software

Aim: To learn how to use the LabScribe software

Approximate Time: 2 hours

Figure T-T-L1: Menus, toolbars, displays and controls of the Main window.

Exercise 1: Recording an ECG

1. Click on the Record button located in the center of the toolbar. The signal should begin 

scrolling across the screen.

2. Click on the AutoScale All button on the toolbar. The ECG signals and heart rate histogram 

should expand to fill the channel windows.

3. Click Stop to halt recording.

4. Click AutoScale All; your record should look like the figure below. 

5. Select Save As in the File menu, type a name for the file. Click on the Save button to save the 

data file.
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Figure T-T-L2: ECG and heart rate data in the LabScribe Main window.

Exercise 2: Explore the LabScribe Main Window

Once you have recorded data, explore some of the functions of the LabScribe software that are 

available on the Main window by clicking on buttons, or pulling down menus and selecting functions. 

See what happens to the images on the recording channels as you change the Display Time, Zoom In or

Out. 

The configuration of the Main window used for this experiment was designed by manipulating some of

the controls on the Main window and some of the controls on other windows, like the Preferences 

dialogue window available from the Edit menu. The configuration used for this experiment was saved 

as the settings file, Tutorial-ECG, that you selected from the Settings menu and are using for this 

experiment.

Additional tools in the LabScribe software are covered in Exercises 3 through 6.
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Figure T-T-L3: Control buttons and values for a typical LabScribe recording channel.

Channel Recording Area

Each channel has its own recording area and its own controls and indicators:

• Channel Menu has controls for inverting and copying the graph, hiding and minimizing the 

channel, changing the title of the channel, converting units, and setting the scale of the Y-axis.

• Right click of the mouse will also show the Channel Menu

• Channel Title, which can be changed through the Channels Menu or the Preferences dialogue 

window.

• Channel Mode and Function identifies the input used and any computed function being 

performed on the input signal. A pull-down setup menu opens when this area is clicked.

• Zoom In button doubles the height of the signal displayed without altering the real amplitude of 

the signal. Zoom Out button halves the height of the signal displayed without altering the real 

amplitude of the signal. 

• AutoScale button increases the height of the signal displayed to within 5% of the upper and the 

lower limits of the Y-axis.

• Add Function button opens a pull-down menu used to select a computed function to be 

performed on the channel. When the function is selected, the additional channel and any 

controls for programming the function open automatically.

• Values lists the Y-value of a data point at the position of a single cursor, or the difference 

between the Y-values of the points identified by two cursors.

• The trace can be positioned within the channel by placing the vertical cursor on the recording 

area, holding down the mouse button, and sliding the trace up or down.

• The height of an individual channel can be adjusted by placing the cursor on the margin 

between that channel and the channel above or below it. The cursor turns into a double-headed 

arrow when it is proper location for adjusting the height of the channel. Hold down the mouse 

button and slide the margin up or down to change the height of the channel display.
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Figure T-T-L4: The Time Display and Mark Controls menu.

Time Displays and Mark Controls

Just above the uppermost channel in the LabScribe Main window are the displays for the time 

parameters of the recording and controls for marking of the recording:

• Speed is the number of samples taken each second of the recording. Sampling rate is controlled 

from the Preferences dialogue window on the Edit menu.

• Display Time is the length of time of recorded data that is seen on the Main window. Display 

time is controlled from the Preferences dialogue window on the Edit menu or by the Display 

Time icons on the LabScribe toolbar.

• Mark button is clicked to place a mark at a point of interest on a recording. Clicking the Enter 

key on the keyboard will also add marks to a recording. 

• Mark Menu is opened by clicking on the arrow to the right of the Mark button. This menu has 

controls for adding and deleting preset marks, and resetting the positions of marks. 

◦ Preset marks can be added to a list by using the Add function in the Marks menu. To 

activate a preset mark for use, click on the arrow at the right side of the Mark Box and select

the preset mark to be used.

• Mark Box is an area where comments are composed. 

• Time or T2-T1 displays the time of the recording at the position of a single cursor, or the 

difference in time between the positions of two cursors placed on the recording.

Figure T-T-L5: The menus, toolbars, displays and controls of the LabScribe Main window.
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Toolbars

Just above the Time Displays and Mark Controls are the toolbars for manipulating data files, LabScribe

windows, time displays, cursors, screen views, and output sequences.

New File: This icon is used to open a new data file using the current settings for the program.

Open File: This icon is used to open data files that were previously recorded and saved.

Save File: This icon is used  to save the current data in a file.

Main Window: This icon is used to return to the window where recorded data is first displayed 

and on-line computed functions can be performed.

Analysis Window: This icon is used to send the data between the left and right margins of the 

Main window to the Analysis window for additional measurements.

FFT: This icon is used to perform a Fast Fourier Transform on data for determining the power 

spectrum of the waveform.

XY Plot: This icon is used to plot the amplitudes of two channels, like pressure and volume, 

against each other.  This plots one channel to another, not one channel to time.

Find Hardware: This icon is used to find the Hardware if it is not recognized by LabScribe.

Journal: This icon is used to open a notepad for recording critical data points, data windows, 

comments, and responses to questions for their eventual transfer to word processing, graphing, 

and other programs used for expressing experimental results.

Meter: Numerical values displayed in an external box to make the data more visible.

Marks: This icon is used to open the list of marks created during the data recording. The 

comments associated with the marks can be edited.
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Stimulator Preferences: This icon is used to open the Stimulator Control Panel under the 

toolbar. The type of stimulus and its parameters are selected from the control panel. The 

stimulator is only needed in experiments that require the generation of action potentials or 

muscle twitches.

Half Display Time: This icon is used to halve the length of the recording displayed on the 

screen. For example, if ten seconds of data is displayed on the screen, clicking this icon will 

display only five seconds.

Zoom Between Cursors: This icon is used to zoom in on a section of data bracketed by the 

cursors.

Double Display Time: This icon is used to double the length of the recording displayed on the 

screen. For example, if ten seconds of data is displayed on the screen, clicking this icon will 

display twenty seconds. 

AutoScale All Channels: This icon is used to scale all the channels to the Y-Axes. This will 

increase the size of the data to be maximized in the window.

Two Cursors: This icon is used to place two cursors on the window. These cursors can be used 

for measuring the differences in time or amplitude for the positions of the two cursors.

One Cursor: This icon is used to place a cursor on the window. This cursor can be used for 

measuring the time and amplitude at the position of the cursor.

Preview: This icon is used to record data without saving to your recording. This is a good way 

to see your data to make sure it looks correct. 

Record: This icon is used to record data that is able to be saved as an iwxdata file.

Views: Displays the controls for creating, copying, naming, and editing views.

Macros: This box displays the name of the sequence of commands used to automate sampling 

and stimulation.
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Exercise 3: Making Marks on a Recording

Large amounts of data can be recorded with LabScribe software. However, to be useful, the data that is 

interesting needs to be located and retrieved easily. Specific sections of data can be located or 

distinguished from other sections by placing marks and comments at those locations in the data file. 

Marks, with or without text comments attached, can be placed on the data during or after the recording. 

The text comments associated with marks can also be composed and saved, before the recording 

begins, in the Preset Mark List.

Entering Marks While Recording

Practice adding marks with comments during a recording.

1. Click Record. Adjust the height of the traces on the ECG and Heart Rate channels by using the 

AutoScale All button.

2. During data recording, click in the Mark Box. Type the subject’s name in the Mark Box using 

the keyboard

3. Click on the Mark button or press the Enter key on the keyboard to place the mark on the 

recording.

4. Use the same procedure to place additional marks and comments while continuing to record 

data.

5. Click on the Stop button to end the recording. Open the File menu and select Save.

Entering Marks on Recorded Data

Additional marks and comments can be added to a data file after the recording is completed.

1. Click on the One Cursor icon on the Main window toolbar.

2. Use the mouse to position the cursor on the data of interest.

3. Put a text cursor in the Mark Box and compose a comment.

4. Click on the Mark button on the Main window, or on the Enter key on the keyboard, to place 

the added mark on the recorded data.

5. Open the File menu and select Save.

Making and Entering Preset Marks

Marks can be composed and added to a list before data recording begins.

1. Before recording another block of data, move the screen cursor to the Mark Box and click the 

mouse button to make a text cursor appear in this box.

2. Write a comment in the Mark Box. Pull down the Mark menu and select Add to Mark Presets.

3. Pull down the Preset Mark List, that is to the right of the Mark Box, and confirm the presence 

of the preset mark you just created.

4. Click Record. Adjust the height of the traces on the ECG and Heart Rate channels by using the 

AutoScale All button.
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5. Pull down the Preset Mark List and select the preset mark you composed. The preset mark 

should appear in the Mark Box.

6. Click on the Mark button on the Main window or press the Enter key on the keyboard to place 

the preset mark on the recording.

7. Click on the Stop button to end the recording. Open the File menu and select Save.

Exercise 4: Analyzing Your Data in the Main Window

Time and amplitude measurements can easily be performed on the Main window using cursors. The 

values obtained can be saved in the Journal along with other notes pertinent to the experiment. 

Navigating the Main Window

There are two ways to navigate through a data file in the Main window to reach regions of interest: 

scrolling or using marks.

Scrolling

1. Locate the scroll bar below the time marks on the lower margin of the Main window. 

2. To move the recording to the left or the right in small increments, click on the arrows at the 

ends of the scroll bar.

3. To scroll slowly through the recording, click on and hold on the arrows at either end of the 

scroll bar.

4. To scroll quickly through the recording, click on and hold on the slider as you move it to the left

or the right. 

5. If you click on the Half or Double Display Time icons on the toolbar, the width of the slider will

change in proportion to the display time of the data file. When the display time on the screen is 

longer, the slider is longer.

Using Marks

1. Open the Marks window to see a list of the marks. The Marks window can be opened by 

clicking the Marks icon on the toolbar. 

2. Click on the Number of the mark to select a mark, click on the GoTo Mark button. The Mark 

window will disappear and the region of the data file around the selected mark will be displayed

on the Main window.
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Figure T-T-L6: The Marks Window.

Making Measurements on the Main Window

Amplitudes, differences in amplitudes, times, and differences in times of waves displayed on the Main 

window can be taken using the cursors. The cursors are vertical red lines that appear on each channel 

displayed in the Main window when either of the two Cursor icons in the toolbar are clicked.

Using two cursors:

1. Click on the Two Cursors icon in the toolbar to place two vertical red bars on the Main window.

2. Click on and drag the cursors, to the left or to the right, to place them on the R waves (largest 

peaks) of two adjacent ECG cycles on the ECG channel. The difference in time between the R 

waves is the value labeled T2-T1, which is displayed in the upper right corner.

Figure T-T-L7: Two cursors used to measure the period (T2-T1) of an ECG cycle.

Tutorial – TutorialECG – Labs T-T-9



3. Keep one cursor on the R wave. Click and drag on the other cursor to place it to the very bottom

left of the largest peak (S wave). This difference in the amplitudes at the cursors is the value 

labeled as V2-V1 which is located below T2-T1.

Figure T-T-L8: Two cursors used to measure the amplitude (V2-V1) of the largest peak of the ECG.

Using a single cursor:

1. Click on the One Cursor icon in the toolbar to place a vertical red line on the Main window.

2. Click on and drag the cursor to a plateau on the Heart Rate channel. The time of the recording at

this position is the value labeled Time1, which is in the upper right corner. The Value for the 

amplitude at this position is the heart rate of the subject at that moment in time.
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Figure T-T-L9: One cursor used to measure the heart rate of the subject from the data on the Heart 

Rate channel.

Exercise 5: Analyzing Your Data in the Analysis Window

Additional analyses can be performed on data displayed in the Analysis window through a number of 

functions that include derivatives, integrals, and general parameters.

Selecting Data for the Analysis Window

1. Locate a ten-second section of the ECG recording with representative ECG waves. Use the 

Display Time icons or the Display Time box on the Preference window to adjust the Display 

Time of the Main window to 10 seconds. 

2. Click on the Analysis icon in the toolbar.
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Figure T-T-10: ECG and heart rate data in the Analysis window.  

Navigating in the Analysis Window

Channels and data are displayed on the Analysis window as they are on the Main window. However, 

you will find that some displays, like Value or Time, will appear in tables above each channel. 

• Scrolling

• Use the slider and arrows on the scroll bar to move the recording to the left or the right.

• Marks

• Use the Go To button on the Marks window to position the data around the selected 

mark in the center of the window.

• Display Time

• Click on Half Display or Double Display Time icons to change the length of the 

recording shown in the window.

• Channel Margins

• Click on and drag the margins between channels to increase or decrease the heights of 

channels.

• Trace Position

• Click on and drag the trace to adjust its vertical position on a channel.  This is the point 

on the cursor at a certain point of the recording.
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• Channel Stacking

• Click on the Stack/Superimpose button in the lower left corner on the 

Analysis window to superimpose the channels upon each other. Click on 

the Stack button, a second time, to stack the channels above and below 

each other.

Figure T-T-L11: The Stack/Superimpose button

• Channel Menu

• Pull down the Channel menu to copy, hide, delete the selected channel, and more. Other 

functions allow data to be copied from the Analysis window to the Journal in tabular 

format

Making Measurements on the Analysis Window

Measurements on data displayed in the Analysis window are performed using cursors and functions 

selected in the following manner:

1. Click on the add function button to open a menu of mathematical functions that can be 

performed on the data displayed in the Analysis window.

2. Open the submenus to familiarize yourself with the parameters available in each category:

• General: provides amplitudes and times of the data at the positions of the cursors, 

differences in amplitudes and times between the data, the maximum and minimum 

values of the data between the cursors, and more.

• Derivative: provides the slope of the data at the positions of the cursors, and the 

maximum, minimum, and mean slope of the data between the cursors.

• Integral: provides the area or absolute area under the recording, or the integral or the 

absolute integral of the recording, between the cursors.

• NIBP and Parameters: Advanced functions used for Research – refer to the LabScribe 

Software User Manual in the Help Menu on the Toolbar.
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Figure T-T-L12: The Add Function menu in the Analysis window.

3. Open the General category and select Value1. Open the General category, three additional 

times, to select Value 2, V2-V1, and T2-T1. After each function is selected, the name of its 

parameter appears on the Function Table. The values of the each parameter on each channel 

appear on a table across the top of each channel.

4. Click on the Two Cursor icon on the toolbar. Place one cursor on the largest peak of an ECG 

cycle displayed on the ECG channel. Place the second cursor on the largest peak of the adjacent

ECG cycle.

5. The values, in the table above the recording area of the ECG channel, are the amplitudes at the 

cursors (Values 1 and 2), the difference in the amplitudes at those cursors (V2-V1), and the time

between the cursors (T2-T1).

6. The values, in the table above the recording area of the Heart Rate channel, are the heart rates at

the cursors (Values 1 and 2), the difference in the heart rates at those cursors (V2-V1), and the 

time between the cursors (T2-T1).

The Journal

The Journal is a window that can be used as a notebook. Notes about the experiment and values from 

measurements on the Main window can be typed directly into the Journal. Also, recordings on the 

screen and data in tables can be copied and pasted into the Journal. From the Journal, the items present 

can be pasted into other programs, or printed directly. 

1. Make sure you are in the Analysis window to use the Journal features.

2. Open the Journal by clicking on the Journal icon on the toolbar.

Tutorial – TutorialECG – Labs T-T-14



3. Click the Editor tab. Use the keyboard to type your name or a note regarding this experiment.

4. Right click on ECG graph, click Copy Graph then paste into your journal by right clicking and 

“pasting” in journal. This will paste an image of your data into the Journal.

5. Click the Table tab.

6. Create a table of your data and their values in the Journal by transferring the titles and the 

values of the parameters with the following steps:

• Right click on any channel and select Add Title to Journal to create a labeled header for 

the table;

• Right click on the Heart Rate channel and select Add Ch. Data to Journal to add data 

from the Heart Rate channel to the table.

7. Click File and Save, this way the Journal gets saved to the data file.

8. Click Journal icon to close the Journal.

Exercise 6: Applying a Computed Function to Your Data

In this exercise, you will learn how to Delete and Add the computed function “Heart Rate”, to your 

ECG recording.

1. Display the ECG data recorded from your subject on the Main window.  

2. Adjust the Display Time of the Main window to ten seconds by

either using the Half or Double Display Time icons on the

toolbar or entering the Display Time in the appropriate box on

the Preferences dialogue window, which is available from the

Edit menu. Click AutoScale All to maximize the trace in the

window.

3. Use the Channel Menu or Right click in the Heart Rate channel

and click Delete and Yes – this will remove the computed

channel from the display.

                                                       Figure T-T-L13: Computed

                                                               Functions Menu
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4. Click the Fx button on the ECG channel. Click Periodic and choose Rate from the drop down 

menu. A new menu and copy of your graph will show up. Click OK in the lower right. This will

add the Rate channel.

                 Figure T-T-L14: The Periodic-Rate setup window.

5. Click on the AutoScale All button on the new computed channel to magnify the trace on that 

channel.                                                        

6. Pull down the Channels menu or Right click on the new computed function channel and select 

Title. Change the name of channel to Heart Rate. Click OK.

7. On the right side of the channel, click V2-V1 and change it to Mean.
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